Maya的arnold当前不可用怎么修改?

  • A+
所属分类:软件教程
广告也精彩

// 警告: file: D:/Program Files/Maya2020/scripts/others/supportRenderers.mel line 67: 此场景使用的渲染器“arnold”当前不可用。将改用“mayaSoftware”渲染器。为防止将来显示此消息,请设置环境变量: MAYA_NO_WARNING_FOR_MISSING_DEFAULT_RENDERER=1

导致此错误的原因有多种:机器上存在旧版本的Arnold(ai.dll)。安装Maya更新后,有时会发生此错误。

解决方法:

安装最新的Arnold更新

如果问题仍然存在,请使用以下过程来解决该行为:

关闭玛雅。

1.下载并安装最新版本的Arnold for Maya (MtoA)

2.将Maya首选项重置为默认值 。

3.启动 Maya。

4.检查插件管理器 mtoa.mll 。

5.Windows>设置/首选项>插件管理器

6.确认在“C:/solidangle/motadeploy/<版本>/plug-in mtoa.mll”下是否已选中(“已加载”(Loaded)、“自动加载”(Autoload)或“基于个人首选项”(both on personal preferences))。

 

1648862091542045

 

如果在执行上述步骤后仍出现以下错误消息,则可能存在问题 mtoa.mod 系统上的文件:

请按照以下过程找到第二个错误:

1.从MtoA根安装文件夹(通常为C:/solidangle/motadeploy/<版本>)中找到mtoa.mod文件。

2.将mota.mod复制到C:\Program Files\Common Files\Autodesk Shared\Modules\Maya\<版本>。

3.将Maya首选项重置为默认值。

4.启动 Maya。

5.再次检查插件管理器 mtoa.mll

Windows>设置/首选项>插件管理器

6.确认在“C:/solidangle/motadeploy/<版本>”下是否已选中/plug-in mtoa.mll(“已加载”(Loaded)、“自动加载”(Autoload)或“基于个人首选项”(bot)。

avatar

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: